NetGen
Generative AI for
Networking

Configure, Query, and Analyze your network in
natural language powered by AI and Large Language Models.

NetGen is our Generative AI application that lets you simply interact with your live network devices and data in endless amount of scenarios. Our Generative AI platform pulls live data from your devices based on your natural language input. NetGen's ability to pull live data empowers increased accuracy and the capability to provide real time AI data analysis. All in our easy-to-use platform. Completely vendor agnostic.

Config Generation

Leverage the combination of ITVA's AI Engine, Large Language Models, and your Network to generate configuration. Simply type the configuration you want and receive the configuration in seconds.

NetGen configuration in action

NetGen
AutoDoc
Devices
Inventory
WebTerminal
User ▼
Arrow Pointing Right
Input:
On the office core switch, bundle interfaces 1 and 5 into LACP interface 15
Arrow Pointing Left
Output:
interface ethernet1
channel-group 15 mode active
interface ethernet5
channel-group 15 mode active

interface port-channel 15

Forget CLI, Embrace Simplicity

  • Configure your devices in
    natural language
  • No need to remember vendor specific CLI
  • Speed up configuration time by
    up to 85%

Batch Configuraton with a Single Command

  • Configure multiple requirements all at once
  • Support for routers, switches, and firewalls
  • Verify output before pushing configuration
NetGen
AutoDoc
Devices
Inventory
WebTerminal
User ▼
Arrow Pointing Right
Input:
On Firewall-1,
Create a prefix-list named PL-DEFAULT-ROUTE permitting 0.0.0.0/0
Create a route-map named RM-ISP-IN permitting prefix-list PL-DEFAULT-ROUTE
Create a BGP peer to 1.1.1.1 with remote-as 1234 and apply RM-ISP-IN
Arrow Pointing Left
Output:
config router prefix-list
    edit "PL-DEFAULT-ROUTE"
        config rule
            edit 1
                set prefix 0.0.0.0/0
                unset ge
                unset le
            next
        end
    next
end
config router route-map
    edit "RM-ISP-IN"
        config rule
            edit 1
                set match-ip-address "PL-DEFAULT-ROUTE"
            next
        end
    next
end
config router bgp
    config neighbor
        edit "1.1.1.1"
            set remote-as 1234
            set route-map-in "RM-ISP-IN"
        next
    end
end

Predictive Impact

Utilize AI analysis and live device data to predict impact and check for conflicts before every change. Within NetGen, Context Helper will provide additional insights from.

Examples of Context Helper

NetGen
AutoDoc
Devices
Inventory
WebTerminal
User ▼
Arrow Pointing Right
Input:
Bundle interfaces xe-0/0/17 and xe-1/0/17 into ae4 on CORE-SWITCH-01
Create subinterface 3124 on ae4 with vlan 3124
Configure ip address 10.13.240.249/29 on ae4.3124
Arrow Pointing Left
Output:
set interfaces xe-0/0/17 ether-options 802.3ad ae4
set interfaces xe-1/0/17 ether-options 802.3ad ae4
set interfaces ae4 aggregated-ether-options minimum-links 1
set interfaces ae4 aggregated-ether-options link-speed 10g
set interfaces ae4 aggregated-ether-options lacp active
set interfaces ae4 unit 3124 vlan-id 3124
set interfaces ae4 unit 3124 family inet address 10.13.240.249/29
Page information icon
Context Helper:

Device(s) detected: CORE-SWITCH-01

Checking for conflicts on CORE-SWITCH-01:

Conflict Detected:

The proposed configuration is attempting to configure xe-1/0/17 with ether-options 802.3ad ae4, but in the current configuration, xe-1/0/17 is already configured with ether-options 802.3ad ae7.

Conflicting portion of the current configuration:

set interfaces xe-1/0/17 ether-options 802.3ad ae7

Additionally, the proposed configuration specifies an IP address 10.13.240.249/29 for ae4 unit 3124, but this IP address is already in use on ae2 unit 1416 in the current configuration.

Conflicting portion of the current configuration:

set interfaces ae2 unit 1416 family inet address 10.13.240.249/29

Minimize Errors, Maximize Reliability

  • Verify configuration conflicts from your proposed configuration to the current configuration
  • Live and current configuration is pulled in real-time
  • Reduce the amount of human errors

Seamlessly Identify and Automate Dependencies

  • Live objection verification for firewalls
  • Find and create dependent objects
  • Reduce configuration time drastically
NetGen
AutoDoc
Devices
Inventory
WebTerminal
User ▼
Arrow Pointing Right
Input:
Create a firewall rule permitting 10.200.10.0/24 to 10.200.11.0/24 on TCP/8000 on EDGE-FW-01 with policy name CORP-ACCESS with utm, av, and ips
Arrow Pointing Left
Output:
config firewall service custom
    edit "UDP-8002"
        set udp-portrange 8002
    next
    edit "TCP-9001"
        set tcp-portrange 9001
    next
end
config firewall policy
    edit 26
        set srcintf "VLAN-10"
        set dstintf "VLAN-11"
        set srcaddr "10.200.10.0/24"
        set dstaddr "10.200.11.0/24"
        set action accept
        set schedule "always"
        set service "UDP-8002" "TCP-9001"
        set name "CORP-ACCESS"
        set utm-status enable
        set av-profile "default"
        set ips-sensor "default"
    next
end
Page information icon
Context Helper:

Virtual Domain(VDOM) referenced: root

Checked next available Policy ID. Results: 26

Checked routing table for next hop interface of source address. Results: ['VLAN-10']

Checked routing table for next hop interface of destination address. Results: ['VLAN-11']

Checked if source address 10.200.10.0/24 exists. Results: True

Checked if destination address 10.200.11.0/24 exists. Results: True

Summary list of address that already exist: ['10.200.10.0/24', '10.200.11.0/24']

Summary list of address that DO NOT yet exist: []

Checked if service UDP-8002 exists. Results: False

Checked if service TCP-9001 exists. Results: False

Checked if AV profile default exists. Results: False List of available AV profiles: ['g-default', 'g-sniffer-profile', 'g-wifi-default']

Checked if IPS sensor default exists. Results: False List of available IPS sensors: ['g-default', 'g-sniffer-profile', 'g-wifi-default', 'all_default', 'all_default_pass', 'high_security', 'protect_client', 'protect_email_server', 'protect_http_server']

Guided Assistance

Our platform detects when you are missing values for a complete configuration, guiding you for the values.

NetGen
AutoDoc
Devices
Inventory
WebTerminal
User ▼
Arrow Pointing Right
Input:
Create a BGP peer to 172.32.16.1 on DATA-CENTER-EDGE-02
Arrow Pointing Left
Output:
set protocols bgp group {{BGP_GROUP}} neighbor 172.32.16.1 peer-as {{PEER_AS}}
Assistant:
Missing values detected. Would you like to update the values?

BGP_GROUP:
PEER_AS:
Update

Streamline Configuration with Intelligent Assistance

  • Eliminate the need to recall each required setting
  • Get clear descriptions of essential configurations
  • Update any missing values quickly

Query Data

Chat with live device information from API calls and Show Commands, all in natural language.

NetGen
AutoDoc
Devices
Inventory
WebTerminal
User ▼
Arrow Pointing Right
Input:
What are all the free 100G ports with an SFP and the port is down on DC-EDGE-10
Arrow Pointing Left
Output:
Here is a summary of QFSP ports on DC-EDGE-10 with status of DOWN:
Ethernet 49/1 - QSFP-100G-LR4
Ethernet 52/1 - QFSP-100G-LR4
Ethernet 53/1 - QFSP-100G-SR4

Instant Data Access, Accelerate Troubleshooting

Retrieve Real-Time Data via Show Commands and APIs
  • Data is pulled live from show commands and API Calls
  • Our AI analyzes the data to answer your question
  • Troubleshoot up to 44% faster

Interactive Data Analysis Through Conversational AI

Engage directly with your data for deeper insights via a chat interface.
  • Quickly pull relevant configuration snippets
  • Chat with your data for further analysis
  • AI data filtering to show only the relevant data you want
NetGen
AutoDoc
Devices
Inventory
WebTerminal
User ▼
Arrow Pointing Right
Input:
On OFFICE-SWITCH-02 Show me my BGP configuration for neighbor 10.255.255.1
Arrow Pointing Left
Output:
router bgp 65400
 neighbor 10.255.255.1 remote-as 65512
 neighbor 10.255.255.1 route-map RM-NEIGHBOR-IN in
 neighbor 10.255.255.1 route-map RM-NEIGHBOR-OUT out

route-map RM-NEIGHBOR-IN permit 10
 match ip address prefix-list PL-NEIGHBOR-IN

route-map RM-NEIGHBOR-OUT permit 10
 match ip address prefix-list PL-NEIGHBOUR-OUT

ip prefix-list PL-NEIGHBOR-IN permit 0.0.0.0/0

ip prefix-list PL-NEIGHBOUR-OUT permit 10.0.0.0/8

Multi-Device Orchestration

Orchestrate Instructions and Queries across multiple devices, providing intelligent abstraction. Regardless of Vendor.

NetGen
AutoDoc
Devices
Inventory
WebTerminal
User ▼
Arrow Pointing Right
Input:
Bundle interfaces xe-0/0/1 and xe-1/0/1 into ae1 on J-CORE-01 and assign IP 10.3.254.1/30
Bundle interfaces ethernet1/1 and ethernet 2/1 into po1 on C-CORE-01 and assign IP 10.3.254.2/30
Arrow Pointing Left
Output:
J-CORE-01:
set interfaces xe-0/0/1 ether-options 802.3ad ae1
set interfaces xe-1/0/1 ether-options 802.3ad ae1
set interfaces ae1 aggregated-ether-options minimum-links 1
set interfaces ae1 aggregated-ether-options link-speed 10g
set interfaces ae1 aggregated-ether-options lacp active
set interfaces ae1 unit 0 family inet address 10.3.254.1/30

C-CORE-01:
interface Ethernet1/1
 channel-group 1 mode active
interface Ethernet2/1
 channel-group 1 mode active
interface Port-Channel
 ip address 10.3.254.2/30

Centralized Orchestration for Streamlined Operations

Manage all network activities from a single, centralized point for better control and simplicity.
  • Configure multiple devices at once
  • Completely vendor agnostic
  • Centralized orchestration

Cross-Device Information Retrieval

Maximize Efficiency with Multi-Device
Search Capabilities.
  • Ask across multiple devices in a folder
  • Search for information across multiple devices
  • Parallelize search efforts
NetGen
AutoDoc
Devices
Inventory
WebTerminal
User ▼
Arrow Pointing Right
Input:
Which devices have mac address ab-23-cd-64-8f-fc in my LA Datacenter
Arrow Pointing Left
Output:
Devices in the LA Datacenter folder:

LA-DC-SWITCH-01:
No Match

LA-DC-SWITCH-02:
interface VLAN100
ARP: 10.200.12.72 - 0ab-23-cd-64-8f-fc

LA-DC-SWITCH-03:
No Match

LA-DC-SWITCH-04:
No Match

LA-DC-SWITCH-05:
interface Ethernet1/13 - MAC - 0ab-23-cd-64-8f-fc

LA-DC-SWITCH-06:
No Match
Try ITVA now, or Contact Us for an Enterprise Demo
No Credit Card Required
Try for freeContact Sales